Powershell是运行在windows机器上实现系统和应用程序管理自动化的命令行脚本环境。 powershell需要.NET环境的支持,同时支持.NET对象。当前powershell有五个版本,分别为1.0,2.0,3.0 ,4.0 5.0。

  • 如果您的系统是window7或者Windows Server 2008,那么PowerShell 2.0已经内置了,可以升级为3.0,4.0。
  • 如果您的系统为Windows 8.1或者Windows server 2012 R2,那默认已经是4.0了。
  • 如果您的系统为Windows 10 使用的就是最新的5.1版本了。

关于powershell 4.0更详细的介绍:Windows Management Framework 4.0 正式版发布


powershell 4.0 需要Windows Management Framework 4.0,下载地址:点击打开链接

  • Windows 7 x64 选择Windows6.1-KB2819745-x64-MultiPkg.msu
  • Windows 7 x86 选择Windows6.1-KB2819745-x86-MultiPkg.msu

Windows Management Framework 4.0 需要 Microsoft .NET Framework 4.5,下载地址:点击打开链接

按官方要求,卸载其他任何 Windows Management Framework 4.0 副本,包括任何预发行副本或其他语言的副本。卸载以下几个,如图:

然后安装先前下载好的Microsoft .NET Framework 4.5,再安装Windows Management Framework 4.0。

安装完以后重启计算机。到此powershell 4.0已成功更新,输入如下命令查看版本,如图:

Last modification:May 11th, 2019 at 07:05 pm
If you think my article is useful to you, please feel free to appreciate